This outage has been resolved. Please see previous note for cause(s) of outage.
Posted Apr 05, 2025 - 12:03 CDT
Monitoring
Our vendor has successfully resolved our DocStar issue, which also fixes the attachments issue.
There were a few things that contributed to this downtime:
1. Credentials to an administrator account had changed, and DocStar server services had relied on this account. To prevent issues like this from happening again, I created a dedicated Epicor service account for the sole purpose of running DocStar & Epicor background services. The vendor then took this new account and applied it to the necessary background services on the appropriate servers. This type of migration takes quite some time.
That new service account I created was then added to all databases.
2. The connection string that enables the databases to talk to DocStar had to be rebuilt, which also took some time. 3. The way that the servers and databases had been configured made it difficult for the vendor to get this work done. It’s a bit of a messy configuration. This will be addressed.
Our vendor is keeping the case open as we test functionality.
Please let me know if you run into any problems, and I will address them promptly.
Posted Apr 02, 2025 - 15:49 CDT
Identified
The vendor has identified the issue. The services on which DocStar relies had been using bad credentials. They have corrected this by using newly created credentials that are to be used solely for Epicor-related applications, and have managed to redeploy the DocStar instance.
Even though DocStar is now running, there is more work that needs to be done. This includes rebuilding the connection string so the application can talk to the database.
IT will continue to work with the vendor and publish updates as they come.
Posted Apr 01, 2025 - 22:10 CDT
Investigating
An issue is occurring with accessing DocStar. When attempting to access DocStar, users will see an error message stating the service is unavailable alongside an HTTP 503 error code. A cause has not yet been identified.
This also affects attachments in Epicor. All users are not able to view, download, upload or otherwise interact with attachments of any kind in any screen or module.
Our Epicor support vendor has been notified and is currently investigating. They are aware this problem is serious, and the support case has been marked as "urgent." Furthermore, they have escalated it so this issue can be resolved in a timely manner. IT has been in regular contact with them today and will remain in contact with them to verify they continue to work on this problem.
Thank you for your patience as these issues are investigated and resolved. All updates will continue to be posted here. Always make sure your notifications preferences are up to date.
Posted Mar 31, 2025 - 06:00 CDT
This incident affected: Epicor (Attachments, DocStar IDC).