The structure of report links has changed. Menu items in Epicor have been updated. You must exit Epicor and sign back in to see these changes. If you have bookmarks in your browser, make sure you update them.
Contact IT if you have any issues or something may have been missed.
Posted Jul 09, 2025 - 08:56 CDT
Investigating
We are aware of and investigating an issue with viewing browser-based (SSRS) reports and some PDF-based reports. Our Epicor support vendor is assisting with the investigation and fix.
Posted Jul 09, 2025 - 07:45 CDT
This incident affected: Epicor (Reporting (SSRS & Crystal Reports)).