Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2025 - 10:00 CDT
Scheduled
Work is being done in the server closet in preparation of the upcoming asbestos removal project. The work in the server closet involves relocating the coaxial cable that goes to the Comcast modem.
Access to Internet may be briefly interrupted.
Posted Jun 30, 2025 - 10:00 CDT
This scheduled maintenance affected: Internet (Comcast (Secondary/Failover)).