All maintenance and other work on Epicor were completed early this evening and into the night. This took much longer than anticipated due to some issues with Epicor components (such as the administration console), but those have been resolved, and their functionalities tested.
Epicor is now fully operational. Additionally, the Positive Pay module has been added and activated for those who require it.
Posted Jul 08, 2025 - 21:28 CDT
Identified
Epicor is currently undergoing further maintenance and is currently unavailable. The support vendor is working on this and is staying in contact with IT. More updates will be posted here.
Posted Jul 08, 2025 - 18:16 CDT
This incident affected: Epicor (Epicor System) and Servers (Epicor and database server (KineticERP)).